package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*product_attribute_2.*?|option value="(\d+)"|<\/select>.*`)
var str = `<select id="product_attribute_1">
<option value="1">2.2 GHz</option>
<option selected="selected" value="2">2.5 GHz</option>
</select>
<select id="product_attribute_2">
<option value="3">2GB</option>
<option value="4">4GB</option>
<option value="5">8GB</option>
</select>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}