$re = '/.*product_attribute_2.*?|option value="(\d+)"|<\/select>.*/s';
$str = '<select id="product_attribute_1">
<option value="1">2.2 GHz</option>
<option selected="selected" value="2">2.5 GHz</option>
</select>
<select id="product_attribute_2">
<option value="3">2GB</option>
<option value="4">4GB</option>
<option value="5">8GB</option>
</select>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);