import re
regex = re.compile(r".*product_attribute_2.*?|option value=\"(\d+)\"|<\/select>.*", flags=re.DOTALL)
test_str = ("<select id=\"product_attribute_1\">\n"
" <option value=\"1\">2.2 GHz</option>\n"
" <option selected=\"selected\" value=\"2\">2.5 GHz</option>\n"
"</select>\n"
"<select id=\"product_attribute_2\">\n"
" <option value=\"3\">2GB</option>\n"
" <option value=\"4\">4GB</option>\n"
" <option value=\"5\">8GB</option>\n"
"</select>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")