#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b"
Local $sString = "Visa:" & @CRLF & _
"Requirements: Visa numbers start with the number 4 and have either 13, 16, or 19 digits (new cards)." & @CRLF & _
"" & @CRLF & _
"Pattern Parts:" & @CRLF & _
"Starts with number 4 and 13 length:" & @CRLF & _
"1) \b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b" & @CRLF & _
"" & @CRLF & _
"Starts with number 4 and 16 length:" & @CRLF & _
"2) \b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b" & @CRLF & _
"" & @CRLF & _
"Starts with number 4 and 19 length:" & @CRLF & _
"3) \b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b" & @CRLF & _
"" & @CRLF & _
"Combining 1-3 to form one pattern:" & @CRLF & _
"\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Test Cases:" & @CRLF & _
"Should fire:" & @CRLF & _
"13 length, no space, start with 4 4123123412341" & @CRLF & _
"13 length, dashes, start with 4 4123-1234-1234-1" & @CRLF & _
"13 length, spaces, start with 4 4123 1234 1234 1" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 4 4221123412341234" & @CRLF & _
"16 length, dashes, start with 4 4221-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 4 4221 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"19 length, no space, start with 4 4241123412341234123" & @CRLF & _
"19 length, dashes, start with 4 4241-1234-1234-1234-123" & @CRLF & _
"19 length, spaces, start with 4 4241 1234 1234 1234-123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Should not fire:" & @CRLF & _
"16 length, no space, not start with 51-55 5623123412341234" & @CRLF & _
"16 length, dashes, not start with 51-55 5623-1234-1234-1234" & @CRLF & _
"16 length, spaces, not start with 51-55 5623 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, not start with 2221-2720 2220123412341234" & @CRLF & _
"16 length, dashes, not start with 2221-2720 2220-1234-1234-1234" & @CRLF & _
"16 length, spaces, not start with 2221-2720 2220 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"Non 16 length, matches 51 pattern start 5123-1234-1234-123" & @CRLF & _
"Non 16 length, matches 2221 pattern start 2221-1234-1234-123" & @CRLF & _
"" & @CRLF & _
"Malformed, matches 51 pattern start 51-2312-34-1234-1234 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")