import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b";
final String string = "Visa:\n"
+ "Requirements: Visa numbers start with the number 4 and have either 13, 16, or 19 digits (new cards).\n\n"
+ "Pattern Parts:\n"
+ "Starts with number 4 and 13 length:\n"
+ "1) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b\n\n"
+ "Starts with number 4 and 16 length:\n"
+ "2) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b\n\n"
+ "Starts with number 4 and 19 length:\n"
+ "3) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b\n\n"
+ "Combining 1-3 to form one pattern:\n"
+ "\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b\n\n\n\n"
+ "Test Cases:\n"
+ "Should fire:\n"
+ "13 length, no space, start with 4 4123123412341\n"
+ "13 length, dashes, start with 4 4123-1234-1234-1\n"
+ "13 length, spaces, start with 4 4123 1234 1234 1\n\n"
+ "16 length, no space, start with 4 4221123412341234\n"
+ "16 length, dashes, start with 4 4221-1234-1234-1234\n"
+ "16 length, spaces, start with 4 4221 1234 1234 1234\n\n"
+ "19 length, no space, start with 4 4241123412341234123\n"
+ "19 length, dashes, start with 4 4241-1234-1234-1234-123\n"
+ "19 length, spaces, start with 4 4241 1234 1234 1234-123\n\n\n\n"
+ "Should not fire:\n"
+ "16 length, no space, not start with 51-55 5623123412341234\n"
+ "16 length, dashes, not start with 51-55 5623-1234-1234-1234\n"
+ "16 length, spaces, not start with 51-55 5623 1234 1234 1234\n\n"
+ "16 length, no space, not start with 2221-2720 2220123412341234\n"
+ "16 length, dashes, not start with 2221-2720 2220-1234-1234-1234\n"
+ "16 length, spaces, not start with 2221-2720 2220 1234 1234 1234\n\n"
+ "Non 16 length, matches 51 pattern start 5123-1234-1234-123\n"
+ "Non 16 length, matches 2221 pattern start 2221-1234-1234-123\n\n"
+ "Malformed, matches 51 pattern start 51-2312-34-1234-1234 \n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}