use strict;
my $str = 'Visa:
Requirements: Visa numbers start with the number 4 and have either 13, 16, or 19 digits (new cards).
Pattern Parts:
Starts with number 4 and 13 length:
1) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b
Starts with number 4 and 16 length:
2) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b
Starts with number 4 and 19 length:
3) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b
Combining 1-3 to form one pattern:
\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b
Test Cases:
Should fire:
13 length, no space, start with 4 4123123412341
13 length, dashes, start with 4 4123-1234-1234-1
13 length, spaces, start with 4 4123 1234 1234 1
16 length, no space, start with 4 4221123412341234
16 length, dashes, start with 4 4221-1234-1234-1234
16 length, spaces, start with 4 4221 1234 1234 1234
19 length, no space, start with 4 4241123412341234123
19 length, dashes, start with 4 4241-1234-1234-1234-123
19 length, spaces, start with 4 4241 1234 1234 1234-123
Should not fire:
16 length, no space, not start with 51-55 5623123412341234
16 length, dashes, not start with 51-55 5623-1234-1234-1234
16 length, spaces, not start with 51-55 5623 1234 1234 1234
16 length, no space, not start with 2221-2720 2220123412341234
16 length, dashes, not start with 2221-2720 2220-1234-1234-1234
16 length, spaces, not start with 2221-2720 2220 1234 1234 1234
Non 16 length, matches 51 pattern start 5123-1234-1234-123
Non 16 length, matches 2221 pattern start 2221-1234-1234-123
Malformed, matches 51 pattern start 51-2312-34-1234-1234
';
my $regex = qr/\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}