# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(src=")\/slm\/attachment\/\d+/$1jira\/rally\/images/gm;t' <<< "src=\"/slm/attachment/63338424306/Note.jpg
src= \" /slm/attachment/63338424306/Note.jpg
src= \"/slm/attachment/63338424306/Note.jpg
src=\" /slm/attachment/63338424306/Note.jpg
"