import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(src=\")/slm/attachment/\\d+";
final String string = "src=\"/slm/attachment/63338424306/Note.jpg\n\n"
+ "src= \" /slm/attachment/63338424306/Note.jpg\n\n"
+ "src= \"/slm/attachment/63338424306/Note.jpg\n\n"
+ "src=\" /slm/attachment/63338424306/Note.jpg\n\n";
final String subst = "$1jira/rally/images";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}