const regex = new RegExp('(src=")/slm/attachment/\\d+', 'gm')
const str = `src="/slm/attachment/63338424306/Note.jpg
src= " /slm/attachment/63338424306/Note.jpg
src= "/slm/attachment/63338424306/Note.jpg
src=" /slm/attachment/63338424306/Note.jpg
`;
const subst = `$1jira/rally/images`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);