# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?>\R?.+){3}\K\R.+//gm;t' <<< "1
00:07:14,120 --> 00:07:16,953
[French line]
[Russian line]
2
00:07:16,960 --> 00:07:19,952
[French line]
[Russian line]
3
00:07:21,240 --> 00:07:24,835
[French line]
[Russian line]"