const regex = /(?>\R?.+){3}\K\R.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>\\R?.+){3}\\K\\R.+', 'gm')
const str = `1
00:07:14,120 --> 00:07:16,953
[French line]
[Russian line]
2
00:07:16,960 --> 00:07:19,952
[French line]
[Russian line]
3
00:07:21,240 --> 00:07:24,835
[French line]
[Russian line]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);