import re
regex = re.compile(r"(?>\R?.+){3}\K\R.+", flags=re.MULTILINE)
test_str = ("1\n"
"00:07:14,120 --> 00:07:16,953\n"
"[French line]\n"
"[Russian line]\n\n"
"2\n"
"00:07:16,960 --> 00:07:19,952\n"
"[French line]\n"
"[Russian line]\n\n"
"3\n"
"00:07:21,240 --> 00:07:24,835\n"
"[French line]\n"
"[Russian line]")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)