import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>\\R?.+){3}\\K\\R.+";
final String string = "1\n"
+ "00:07:14,120 --> 00:07:16,953\n"
+ "[French line]\n"
+ "[Russian line]\n\n"
+ "2\n"
+ "00:07:16,960 --> 00:07:19,952\n"
+ "[French line]\n"
+ "[Russian line]\n\n"
+ "3\n"
+ "00:07:21,240 --> 00:07:24,835\n"
+ "[French line]\n"
+ "[Russian line]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}