#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?<!\S)(?!\*+\d)[a-zA-Z]*\*[a-zA-Z*]*"
Local $sString = "(A) Match these:" & @CRLF & _
" *** star* st**r" & @CRLF & _
"" & @CRLF & _
" (B) Not these:" & @CRLF & _
" 800*m *4,500 " & @CRLF & _
"" & @CRLF & _
" (C) And not these:" & @CRLF & _
" 800**m **4,000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")