import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?!\\*+\\d)[a-zA-Z]*\\*[a-zA-Z*]*";
final String string = "(A) Match these:\n"
+ " *** star* st**r\n\n"
+ " (B) Not these:\n"
+ " 800*m *4,500 \n\n"
+ " (C) And not these:\n"
+ " 800**m **4,000";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}