$re = '/(?<!\S)(?!\*+\d)[a-zA-Z]*\*[a-zA-Z*]*/x';
$str = '(A) Match these:
*** star* st**r
(B) Not these:
800*m *4,500
(C) And not these:
800**m **4,000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);