#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msxi)#https://www.native-english.ru/grammar/english-nouns-plural" & @CRLF & _
"" & @CRLF & _
"(?<![a-z]) #word boundary" & @CRLF & _
"(?: [a-z]+ [bcdfghjklmnpqrtvwzeoya]s" & @CRLF & _
" | [a-z]+ (?:[sc]h|[sxoiv])es" & @CRLF & _
" | children|men|women|mice|teeth|feet|geese|oxen|deer|sheep|swine" & @CRLF & _
")" & @CRLF & _
"$"
Local $sString = "area" & @CRLF & _
"areas" & @CRLF & _
"" & @CRLF & _
"child" & @CRLF & _
"children" & @CRLF & _
"man" & @CRLF & _
"men" & @CRLF & _
"woman" & @CRLF & _
"women" & @CRLF & _
"mouse" & @CRLF & _
"mice" & @CRLF & _
"tooth" & @CRLF & _
"teeth" & @CRLF & _
"foot" & @CRLF & _
"feet" & @CRLF & _
"goose" & @CRLF & _
"geese" & @CRLF & _
"" & @CRLF & _
"ox" & @CRLF & _
"oxen" & @CRLF & _
"" & @CRLF & _
"deer" & @CRLF & _
"sheep" & @CRLF & _
"swine" & @CRLF & _
"" & @CRLF & _
"cat" & @CRLF & _
"cats" & @CRLF & _
"bus" & @CRLF & _
"buses" & @CRLF & _
"moon" & @CRLF & _
"moones" & @CRLF & _
"" & @CRLF & _
"class" & @CRLF & _
"classes" & @CRLF & _
"box" & @CRLF & _
"boxes" & @CRLF & _
"bush" & @CRLF & _
"bushes" & @CRLF & _
"inch" & @CRLF & _
"inches" & @CRLF & _
"match" & @CRLF & _
"matches" & @CRLF & _
"" & @CRLF & _
"shelf" & @CRLF & _
"shelves" & @CRLF & _
"wive" & @CRLF & _
"wives" & @CRLF & _
"" & @CRLF & _
"chief" & @CRLF & _
"chiefs" & @CRLF & _
"roof" & @CRLF & _
"roofs" & @CRLF & _
"safe" & @CRLF & _
"safes" & @CRLF & _
"" & @CRLF & _
"army" & @CRLF & _
"armies" & @CRLF & _
"city" & @CRLF & _
"cities" & @CRLF & _
"employee" & @CRLF & _
"employees" & @CRLF & _
"" & @CRLF & _
"day" & @CRLF & _
"days" & @CRLF & _
"toy" & @CRLF & _
"toys" & @CRLF & _
"boy" & @CRLF & _
"boys" & @CRLF & _
"" & @CRLF & _
"hero" & @CRLF & _
"heroes" & @CRLF & _
"potato" & @CRLF & _
"potatoes" & @CRLF & _
"tomato" & @CRLF & _
"tomatoes" & @CRLF & _
"" & @CRLF & _
"solo" & @CRLF & _
"solos" & @CRLF & _
"radio" & @CRLF & _
"radios" & @CRLF & _
"photo" & @CRLF & _
"photos" & @CRLF & _
"piano" & @CRLF & _
"pianos"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")