// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?msxi)#https://www.native-english.ru/grammar/english-nouns-plural
(?<![a-z]) #word boundary
(?: [a-z]+ [bcdfghjklmnpqrtvwzeoya]s
| [a-z]+ (?:[sc]h|[sxoiv])es
| children|men|women|mice|teeth|feet|geese|oxen|deer|sheep|swine
)
$").unwrap();
let string = "area
areas
child
children
man
men
woman
women
mouse
mice
tooth
teeth
foot
feet
goose
geese
ox
oxen
deer
sheep
swine
cat
cats
bus
buses
moon
moones
class
classes
box
boxes
bush
bushes
inch
inches
match
matches
shelf
shelves
wive
wives
chief
chiefs
roof
roofs
safe
safes
army
armies
city
cities
employee
employees
day
days
toy
toys
boy
boys
hero
heroes
potato
potatoes
tomato
tomatoes
solo
solos
radio
radios
photo
photos
piano
pianos";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}