use strict;
my $str = 'area
areas
child
children
man
men
woman
women
mouse
mice
tooth
teeth
foot
feet
goose
geese
ox
oxen
deer
sheep
swine
cat
cats
bus
buses
moon
moones
class
classes
box
boxes
bush
bushes
inch
inches
match
matches
shelf
shelves
wive
wives
chief
chiefs
roof
roofs
safe
safes
army
armies
city
cities
employee
employees
day
days
toy
toys
boy
boys
hero
heroes
potato
potatoes
tomato
tomatoes
solo
solos
radio
radios
photo
photos
piano
pianos';
my $regex = qr~#https://www.native-english.ru/grammar/english-nouns-plural
(?<![a-z]) #word boundary
(?: [a-z]+ [bcdfghjklmnpqrtvwzeoya]s
| [a-z]+ (?:[sc]h|[sxoiv])es
| children|men|women|mice|teeth|feet|geese|oxen|deer|sheep|swine
)
$~msxip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}