const regex = /(mother|father)(.*?)(?!\1)((?1))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(mother|father)(.*?)(?!\\1)((?1))', 'gm')
const str = `Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
something else mother a father a father mother blablö mother and father
not this mother mother or
or father father but this
Non-matches:
just mother
just father
mother then mother
father then father
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}