re = /(mother|father)(.*?)(?!\1)((?1))/m
str = 'Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
something else mother a father a father mother blablö mother and father
not this mother mother or
or father father but this
Non-matches:
just mother
just father
mother then mother
father then father
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end