const regex = /(?<=PLUS(?:(?!SC).){29})SC/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=PLUS(?:(?!SC).){29})SC', 'gm')
const str = `PLUS This is a AC and this is an SC too
PLUS This is a SC and this is an SC too`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}