re = /(?<=PLUS(?:(?!SC).){29})SC/m
str = 'PLUS This is a AC and this is an SC too
PLUS This is a SC and this is an SC too'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end