using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([.?!;:,])(.)";
string input = @"ну что.не смотрел еще black mesa.я собирался скачат ь,но все как-то некогда было.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}