$re = '/([.?!;:,])(.)/mui';
$str = 'ну что.не смотрел еще black mesa.я собирался скачать,но все как-то некогда было.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);