package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([.?!;:,])(.)`)
var str = `ну что.не смотрел еще black mesa.я собирался скачать,но все как-то некогда было.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}