re = /([.?!;:,])(.)/mi
str = 'ну что.не смотрел еще black mesa.я собирался скачать,но все как-то некогда было.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end