#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[a-z\d]+-?)*?(?:/|(?=20\d{2}-?){1,2})"
Local $sString = "abc-def/something/else/ [incl. slash if there is not character before it]" & @CRLF & _
"abc-def-2019/something/else/" & @CRLF & _
"abc-def-2019-2020/something/else/" & @CRLF & _
"abc-def-125-2019/something/else/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)