re = /^(?:[a-z\d]+-?)*?(?:\/|(?=20\d{2}-?){1,2})/m
str = 'abc-def/something/else/ [incl. slash if there is not character before it]
abc-def-2019/something/else/
abc-def-2019-2020/something/else/
abc-def-125-2019/something/else/'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result