$re = '~^(?:[a-z\d]+-?)*?(?:/|(?=20\d{2}-?){1,2})~m';
$str = 'abc-def/something/else/ [incl. slash if there is not character before it]
abc-def-2019/something/else/
abc-def-2019-2020/something/else/
abc-def-125-2019/something/else/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;