use strict;
my $str = 'abc-def/something/else/ [incl. slash if there is not character before it]
abc-def-2019/something/else/
abc-def-2019-2020/something/else/
abc-def-125-2019/something/else/';
my $regex = qr~^(?:[a-z\d]+-?)*?(?:/|(?=20\d{2}-?){1,2})~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";