using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^@]*@[^@]*$";
string input = @"@foobar
foo@bar
foobar@
fooba@r
@@foobar
@foo@bar
foo@b@ar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}