re = /^[^@]*@[^@]*$/m
str = '@foobar
foo@bar
foobar@
fooba@r
@@foobar
@foo@bar
foo@b@ar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end