package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^@]*@[^@]*$`)
var str = `@foobar
foo@bar
foobar@
fooba@r
@@foobar
@foo@bar
foo@b@ar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}