$re = '/^[^@]*@[^@]*$/m';
$str = '@foobar
foo@bar
foobar@
fooba@r
@@foobar
@foo@bar
foo@b@ar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);