using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!(?:word1|word2)\b)\w+";
string input = @"Basically I need a regex which will return true if the string is a word (\w+) EXCEPT if it is the word word1 OR word2.";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}