const regex = /\b(?!(?:word1|word2)\b)\w+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:word1|word2)\\b)\\w+', 'gu')
const str = `Basically I need a regex which will return true if the string is a word (\\w+) EXCEPT if it is the word word1 OR word2.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}