re = /\b(?!(?:word1|word2)\b)\w+/
str = 'Basically I need a regex which will return true if the string is a word (\\w+) EXCEPT if it is the word word1 OR word2.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end