$re = '/\b(?!(?:word1|word2)\b)\w+/u';
$str = 'Basically I need a regex which will return true if the string is a word (\\w+) EXCEPT if it is the word word1 OR word2.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);