#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d+\.(?=[^\r\n|]*$)"
Local $sString = "blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)