$re = '/\d+\.(?=[^\r\n|]*$)/m';
$str = 'blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;