const regex = /\d+\.(?=[^\r\n|]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\.(?=[^\\r\\n|]*$)', 'gm')
const str = `blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);