re = /\d+\.(?=[^\r\n|]*$)/m
str = 'blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result