package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w.]+:.+\|.\|#(?:[\w.]+:[^,\n]+(?:,|$))*$`)
var str = `performance.os.disk:1099511627776|g|#region:us-west-1,datacenter:us-west-1a
performance.os.disk:1099511627776|g|#
performance.os.disk:1099511627776|g|#region:us-west-1
datastore.reads:9876|ms`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}