use strict;
my $str = 'performance.os.disk:1099511627776|g|#region:us-west-1,datacenter:us-west-1a
performance.os.disk:1099511627776|g|#
performance.os.disk:1099511627776|g|#region:us-west-1
datastore.reads:9876|ms';
my $regex = qr/^[\w.]+:.+\|.\|#(?:[\w.]+:[^,\n]+(?:,|$))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}