$re = '/^[\w.]+:.+\|.\|#(?:[\w.]+:[^,\n]+(?:,|$))*$/m';
$str = 'performance.os.disk:1099511627776|g|#region:us-west-1,datacenter:us-west-1a
performance.os.disk:1099511627776|g|#
performance.os.disk:1099511627776|g|#region:us-west-1
datastore.reads:9876|ms';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);