const regex = /^[\w.]+:.+\|.\|#(?:[\w.]+:[^,\n]+(?:,|$))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w.]+:.+\\|.\\|#(?:[\\w.]+:[^,\\n]+(?:,|$))*$', 'gm')
const str = `performance.os.disk:1099511627776|g|#region:us-west-1,datacenter:us-west-1a
performance.os.disk:1099511627776|g|#
performance.os.disk:1099511627776|g|#region:us-west-1
datastore.reads:9876|ms`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}