import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{28}$)(?:[A-Za-z0-9+/]{4})+[A-Za-z0-9+/]{2,3}==?$";
final String string = "platformAndroidSignatureHash\n"
+ "2pmj9i4rSx0yEb/viWBYkE/ZQrk=\n"
+ "aPz8/NARbPz8pPzg/Iz9aPz8NCg=\n"
+ "aPz8/NARbPz8pPzg/Iz9aPz8NC==\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}