$re = '`^(?=.{28}$)(?:[A-Za-z0-9+/]{4})+[A-Za-z0-9+/]{2,3}==?$`m';
$str = 'platformAndroidSignatureHash
2pmj9i4rSx0yEb/viWBYkE/ZQrk=
aPz8/NARbPz8pPzg/Iz9aPz8NCg=
aPz8/NARbPz8pPzg/Iz9aPz8NC==
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);