const regex = /(?i)(?<!\d)(?:0?[1-9]|1[0-2])(?::[0-5]\d)?\p{Pd}(?:0?[1-9]|1[0-2])(?::[0-5]\d)?[ap]m\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<!\\d)(?:0?[1-9]|1[0-2])(?::[0-5]\\d)?\\p{Pd}(?:0?[1-9]|1[0-2])(?::[0-5]\\d)?[ap]m\\b', 'gm')
const str = `bla bla 1:30-2pm bla bla 5-6:30am some text 1-2:15am
bla bla 1:30-2pm bla bla 5:23—6:30am some text 1—2:15am`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}